Boost logo

Boost :

From: Matthew Austern (austern_at_[hidden])
Date: 2001-11-29 13:15:08

David Abrahams wrote:
> I think I've been misinterpreted: I'm not trying to fix type2type, though I
> don't love the name. I was just exploring some ideas.

For what it's worth, I like your *_wrapper names. I'm not sure if
I can articulate a reason why I like them a bit better than Andrei's
names, but I'll try.

First the "2" in the name, for "to", isn't used anywhere
in the standard. It seems like a slightly different style.

Second, and this might expose a real philosophical difference
(perhaps a misunderstanding on my part), Andrei's names are
names of actions, not things. I realize it's possible to
think of metaprogramming classes as higher-order functions,
but I still feel slightly uncomfortable giving a class a
name that connotes a function; I think of a class as something
that is, not something that does.


Boost list run by bdawes at, gregod at, cpdaniel at, john at