Boost logo

Boost :

From: Darin Adler (darin_at_[hidden])
Date: 2001-11-29 13:20:42

On 11/29/01 10:15 AM, "Matthew Austern" <austern_at_[hidden]> wrote:

> For what it's worth, I like your *_wrapper names. I'm not sure if
> I can articulate a reason why I like them a bit better than Andrei's
> names, but I'll try.
> First the "2" in the name, for "to", isn't used anywhere
> in the standard. It seems like a slightly different style.
> Second, and this might expose a real philosophical difference
> (perhaps a misunderstanding on my part), Andrei's names are
> names of actions, not things. I realize it's possible to
> think of metaprogramming classes as higher-order functions,
> but I still feel slightly uncomfortable giving a class a
> name that connotes a function; I think of a class as something
> that is, not something that does.

I also prefer the *_wrapper names, for the same two reasons.

    -- Darin

Boost list run by bdawes at, gregod at, cpdaniel at, john at