Boost logo

Boost :

From: jhrwalter (walter_at_[hidden])
Date: 2002-01-17 09:51:52

--- In boost_at_y..., Toon Knapen <toon.knapen_at_s...> wrote:
> I find the size1() and size2() not very intuitive unless their
names are
> chosen to align with the storage (major-row ?) in which case I
think the
> name breaks encapsulation.

size1() and size2() do not align with the storage order. size1()
means the number of matrix rows and size2() means the number of
matrix columns independent from the storage organization.

> Would'nt it be easier to just call them nrows() and ncols() for
instance ?

This could be a good question for a poll ;-). We opted for size1()
and size2() because of compatibility to multidimensional arrays.

BTW, the same question arises for index1()/index2() and



Boost list run by bdawes at, gregod at, cpdaniel at, john at