From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-01-24 15:14:42
----- Original Message -----
From: "bill_kempf" <williamkempf_at_[hidden]>
Sent: Thursday, January 24, 2002 3:03 PM
Subject: [boost] Re: Draft of generation 2 thread class
> --- In boost_at_y..., "David Abrahams" <david.abrahams_at_r...> wrote:
> > ----- Original Message -----
> > From: "bill_kempf" <williamkempf_at_h...>
> > > Actually, this makes me wonder if the name shouldn't be more
> > > the lines of pending_cancellation()?
> > That was my inclination. Others along those lines:
> > cancel_posted
> > cancel_pending
> > cancel_requested
> One reason I don't like "pending" is that it seems to indicate that
> once the thread is cancelled the result will then be false, but that
> constrains implementation in ways I don't care for. So I guess I
> like cancel_posted or cancel_requested better. Thoughts?
Which one makes cancel seem less like a verb?
I guess "cancellation_requested" is the clearest of all.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk