Boost logo

Boost :

From: Rainer Deyke (root_at_[hidden])
Date: 2002-01-30 15:40:49


----- Original Message -----
From: "Aleksey Gurtovoy" <alexy_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Wednesday, January 30, 2002 12:25 PM
Subject: RE: [boost] Objections to removing the old smart pointer
class templates?

> Darin Adler wrote:
> > I'm going to remove the old smart pointer class templates,
replacing
> > <boost/smart_ptr.hpp> with:
> >
> > #include <boost/scoped_ptr.hpp>
> > #include <boost/scoped_array.hpp>
> > #include <boost/shared_ptr.hpp>
> > #include <boost/shared_array.hpp>
> > #include <boost/weak_ptr.hpp>
>
> Why not
>
> #include <boost/memory/scoped_ptr.hpp>
> #include <boost/memory/scoped_array.hpp>
>
> etc., or something like this?

IMO 'memory' is a bad name since the smart pointer classes deal with
fully constructed objects, not raw memory. Maybe
<boost/smart_ptr/scoped_ptr.hpp>?

--
Rainer Deyke | root_at_[hidden] | http://rainerdeyke.com

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk