Boost logo

Boost :

From: Peter Dimov (pdimov_at_[hidden])
Date: 2002-02-11 15:21:50

From: "Darin Adler" <darin_at_[hidden]>
> I think that both of these things would be valuable. But I think that
> defining a new language is quite difficult. So I think we should do A
> It's also clear that the best syntax for A would be the same as C printf
> syntax:
> format("%s %d", str, i);

Agreed except that I'd name that particular function sprintf, not format.
There should probably be a vsprintf as well that takes std::vector<
shared_ptr<streamable> > or similar.

Boost list run by bdawes at, gregod at, cpdaniel at, john at