Boost logo

Boost :

From: Karl Nelson (kenelson_at_[hidden])
Date: 2002-02-11 17:19:24

> From: "Darin Adler" <darin_at_[hidden]>
> > I think that both of these things would be valuable. But I think that
> > defining a new language is quite difficult. So I think we should do A
> first.
> > It's also clear that the best syntax for A would be the same as C printf
> > syntax:
> >
> > format("%s %d", str, i);
> Agreed except that I'd name that particular function sprintf, not format.
> There should probably be a vsprintf as well that takes std::vector<
> shared_ptr<streamable> > or similar.

There really isn't much "print" in sprintf. It was a bad name to
begin with. How about boost::legacy::format for the old style of
printf-like formatting? At least partially separating this debate.

Hopefully we can keep a similar syntax between boost::format and
boost::legacy::format. Though I would still really prefer to make
a format which accepts printf and some extension like %{1:my_format_type}.


Boost list run by bdawes at, gregod at, cpdaniel at, john at