Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2002-04-08 19:54:21

At 08:04 AM 4/7/2002, Peter Dimov wrote:

>I'm not convinced that even leaving get() in is a good idea. We
>probably rename it to unsafe_get() since no matter how red, bold, and

>large we make the warning in the documentation, people will ignore

While the standard was being developed, Nathan Myers wanted get() to be
renamed leak().

>> Well, I don't know - presumably a more parameterized smart pointer
>> would (at least with some parameter combinations) duplicate the
>> functionality of shared_ptr, which would then make shared_ptr
>> redundant.
>That was the plan.
>The main problem with policy-based pointer proposals so far is that
>nobody actually sat down and did the work. The only serious proposal
>is Andrei's Loki::SmartPtr, which doesn't support (out of the box)
>neither the array versions nor the current shared_ptr, and nobody has
>expressed willingness to write the necessary paperwork (formal spec,
>tests, docs, that sort of thing.)
>Saying "why don't we make a policy-based smart pointer" on the list
>not enough (this is not aimed at you personally, merely a general

Very true. Smart pointers have proven very, very, hard to get right. We
owe a vote of thanks to Peter, Greg and the others who have been
willing to put in the long term effort.


Boost list run by bdawes at, gregod at, cpdaniel at, john at