Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2002-04-11 11:14:25

  I agree with your comment that it is unclear that:

boost::signal<int, int, int>::combiner<maximum<int> >::type sig_max;
  declares a signal and not a combiner. I believe that instead of just
renaming 'combiner' to 'with_combiner', Signals should adopt the named
template parameters format used in the iterator adaptors library, so the
above would become:
  boost::signal<int, int, int,
                boost::signals::combiner_is<maximum<int> > sig_max;

With a few using declarations it would be more readable:

  boost::signal<int, int, int, combiner_is<maximum<int> > > sig_max;

This syntax is clearer to me; does it work for you as well?


On Thursday 11 April 2002 06:02 am, you wrote:
> Doug,
> I posted a remark
> regarding the nested combiner typedef in class signal (Yes I missed the
> deadline with that, my fault). I would really appreciate a comment on this
> one.
> Thanks
> Thomas

Boost list run by bdawes at, gregod at, cpdaniel at, john at