Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-04-11 11:44:19

----- Original Message -----
From: "Douglas Gregor" <gregod_at_[hidden]>
To: <boost_at_[hidden]>
Sent: Thursday, April 11, 2002 11:14 AM
Subject: Re: [boost] Signals library nearing CVS integration

> Thomas,
> I agree with your comment that it is unclear that:
> boost::signal<int, int, int>::combiner<maximum<int> >::type sig_max;
> declares a signal and not a combiner. I believe that instead of just
> renaming 'combiner' to 'with_combiner', Signals should adopt the named
> template parameters format used in the iterator adaptors library, so
> above would become:
> boost::signal<int, int, int,
> boost::signals::combiner_is<maximum<int> > sig_max;
> With a few using declarations it would be more readable:
> boost::signal<int, int, int, combiner_is<maximum<int> > > sig_max;
> This syntax is clearer to me; does it work for you as well?

Something to consider: In Boost.Python v2 I recently considered using
NTP, but then determined that it was simpler for users and implementor
to deduce the role of each parameter from its type. I'm not sure that's
possible in your case, but I thought I'd bring it up just in case.


Boost list run by bdawes at, gregod at, cpdaniel at, john at