Boost logo

Boost :

From: Hamish Mackenzie (hamish_at_[hidden])
Date: 2002-04-14 08:20:16

I think a lot of confusion has resulted from people, including myself,
thinking that mpl::type_list and loki::type_list are (or should be) the
same thing. Both have advantages and disadvantages.

If mpl and loki are to be integrated it is loki::type_list and
mpl::list_node that need to be merged.

This will have implications. Here are the ones I can see

* To use a mpl::type_list with a loki class you will have to use ::type
eg. mpl::type_list< int, float >::type
This problem should go away once template typedefs are available.

* To use other mpl containers with loki you will need to convert them (I
assume this is a common requirement with a simple solution).

I think loki::type_list should be renamed to list_node as soon as
possible, to avoid future confusion.

This would leave us with
  mpl::type_list == loki::TYPE_LIST_NN
  mpl::list_node == loki::list_node


Boost list run by bdawes at, gregod at, cpdaniel at, john at