From: Hamish Mackenzie (hamish_at_[hidden])
Date: 2002-04-15 07:54:00
Please ignore this version of my post as it is an early draft that got
stuck on the mailing list server for almost a whole day (I think it was
because the from address was not the one I was using to receive boost at
On Sun, 2002-04-14 at 14:20, Hamish Mackenzie wrote:
> I think a lot of confusion has resulted from people, including myself,
> thinking that mpl::type_list and loki::type_list are (or should be) the
> same thing. Both have advantages and disadvantages.
> If mpl and loki are to be integrated it is loki::type_list and
> mpl::list_node that need to be merged.
> This will have implications. Here are the ones I can see
> * To use a mpl::type_list with a loki class you will have to use ::type
> eg. mpl::type_list< int, float >::type
> This problem should go away once template typedefs are available.
> * To use other mpl containers with loki you will need to convert them (I
> assume this is a common requirement with a simple solution).
> I think loki::type_list should be renamed to list_node as soon as
> possible, to avoid future confusion.
> This would leave us with
> mpl::type_list == loki::TYPE_LIST_NN
> mpl::list_node == loki::list_node
> Unsubscribe & other changes: http://lists.boost.org/mailman/listinfo.cgi/boost
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk