Boost logo

Boost :

From: Vesa Karvonen (vesa_karvonen_at_[hidden])
Date: 2002-04-17 00:38:28

David Abrahams:
> 1. I think it would be a lot clearer if the names of formal parameters
> to macros were not ALL_UPPERCASE. A little variation helps to
> distinguish what's going on, and, after all, there's no reason to use
> ALL_UPPERCASE for macro params (is there?)
> 2. Callable macro args should probably be called "function", not
> "MACRO", since the former describes how they act in the lib context and
> since there are non-function macros.

MACRO is currently used for parameters that are directly used for producing output from the (higher order) macro. For instance, BOOST_PP_REPEAT() takes a MACRO as does BOOST_PP_FOR(). BOOST_PP_FOR() also takes two more function like macros as parameters (PRED and OP), but those are not used for producing output.

I suppose MACRO isn't the best name, but "function" isn't much better either.

Boost list run by bdawes at, gregod at, cpdaniel at, john at