Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2002-05-24 20:14:43


At 09:00 AM 5/23/2002, Douglas Gregor wrote:

>We can't just replace the 'signals' namespace with a (user-defined, but
>defaulted) macro BOOST_SIGNALS_NAMESPACE because that doesn't play nicely

>with (shared) libraries.
>
>Here's a possibility: the Signals library moves from the boost::signals
>namespace to the boost::signalslib namespace (better names anyone?
please?).
>
>Then the Signals library also has this:
>
>#ifndef signals
>namespace boost {
> namespace signalslib {}
> namespace signals = signalslib;
>}
>#endif
>
>So when Qt is not available, the boost::signals namespace alias is used
and
>nobody knows the difference (would someone confirm this? I haven't needed

>namespace aliases before...)...

Ugly. Think about it long and hard. As Boost gets used with more and more
third party libraries, we are going to run into this sort of problem more
often.

Do we really want to change our libraries because of the rudeness of
others?

--Beman


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk