Boost logo

Boost :

From: Terje Slettebø (tslettebo_at_[hidden])
Date: 2002-05-24 18:27:34

>From: "Beman Dawes" <bdawes_at_[hidden]>

> At 03:30 PM 5/24/2002, Jaakko Jarvi wrote:
> >The BLL tests seem to compile and run with Intel 6.0 without any
> >options (except for -Iboost). My icpc.cfg file has these defined
> >though:
> >
> >-tp p6
> >-long_double
> >
> >-D__int64="long long"
> >
> >Adding the options from boost/status/compiler.cfg for icc-strict seems
> >cause problems though. I haven't really played with the options yet.
> Are you working with the Windows or Linux version of Intel 6.0?
> I should have specified that Terje and I were working with the Windows
> version.

Exactly. This is something I've experienced before, too, that something
worked on the Linux version, but not on the Windows version. I guess it's
because there's no MSVC on Linux, so it doesn't run in default MSVC mode,

One thing you may try right away, and which looks very promising, is to add
the option "-Qoption,cpp,--no_microsoft".

That gives a lot of different error messages, instead, here. :) I'm using
STLPort, but still using the streams part of the MSVC library, and it turns
out that there's a lot of bugs in the MSVC library, that become apparent
when you turn on that option. There's a bunch of "typename"s missing (for
dependent types), redefinitions of template arguments, etc. I started going
through the error messages, fixing these errors in the MSVC library, but
there appears to be even more serious errors, there, which aren't as easily

Therefore, I've found that it's probably best that I install the full
version of STLPort, including building it, so it uses its own streams. If
you do this, it may well compile. I'm going to try this, when I get a

Enabling that option seemed to bring out the true animal in the compiler. :)

It appears that with it, it compiles in "strict" mode, or standards
compliant mode.

> I'd like to get the full set of jam regression tests working for
> Lambda and everything else.
> Actually, the regular intel-win32 toolset in CVS already "works" in the
> sense the compiles run, but a bunch of tests are failing, apparently
> because the default is to emulate the Microsoft compiler, bugs and all:-(
> That's what I was hoping someone has a workaround for.

Try the above. :)

I see that David suggests a similar option, which does the same, except that
it doesn't disable the extensions, and that he, too suggests STLPort. I
tried that option as well, now, and it gives the same error messages, for
the MSVC library, at least for the version of the MSVC library I have (for
MSVC 6).



Boost list run by bdawes at, gregod at, cpdaniel at, john at