Boost logo

Boost :

From: Dietmar Kuehl (dietmar_kuehl_at_[hidden])
Date: 2002-06-27 19:42:01

On Thursday 27 June 2002 09:06, Daniel Frey wrote:
> As I already said, I don't consider it a good idea to create a new style
> of how to use the STL.

Here our opinions obviously differ but for the purpose of array_traits.hpp
it does not really matter: This should probably just contain the stuff you
put there (maybe with minor additions if someone cares about them strongly).
Actually, I find myself writing 'begin()' and 'end()' functions for array
quite often because there is no header doing it. This should really be

> Even inside the STL, replacing one container with
> another isn't as easy as you'd wish, but I know you know that :) If it
> is still important for you, would you consider separating it to another
> header/library?

I will probably go this way eventually: there are more necessary changes to
the STLvthan merely making the function global ones...

<mailto:dietmar_kuehl_at_[hidden]> <>
Phaidros eaSE - Easy Software Engineering: <>

Boost list run by bdawes at, gregod at, cpdaniel at, john at