Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-07-02 09:24:16

From: "Martin Wille" <mw8329_at_[hidden]>

> A variant basically is a union (be it typesafe or not). The process
> of interpreting a unions value as of being of a specific type can be
> referred to as putting a view onto it. So, view<>, view_as<> or even
> as<> might be fitting names. Prefixing these with "variant_" might
> make sense.

My only problem with the "variant_" prefix is that we're talking about
introducing a class template called variant, but also about making this a
general-purpose function which applies to all kinds of different types. I
think that's confusing at best.


Boost list run by bdawes at, gregod at, cpdaniel at, john at