Boost logo

Boost :

From: Eric Friedman (ebf_at_[hidden])
Date: 2002-07-24 00:55:54

The following excerpt is from a private conversation with Aleksey:

> > [Eric]
> > Any possibility that if_ will return in name to select_if? I find
> > select_if to be a superior name for the following reasons:
> >
> > if_ is visually distracting; OTOH select_if is visually-similar to

> > apply_if.
> > if_ is a bad analogy to runtime C++. In runtime C++ the if keyword

> > invokes code, ?: operator selects a value. So if anything, apply_if
> > should be named if_, as it invokes a metafunction -- I don't think
> > anyone wants this, however, so I think if_ should give way to
> > select_if (and apply_if should remain as it is now).
> [Aleksey]
> I suggest that you raise this issue on the list. I myself like the
> shortness of "if_", but I'll go with consensus here - given that there
> is one :).

So I am raising the issue to the list.

An additional advantage of the "select_if" name over "if_" is that the
#include "boost/mpl/[metafunction-name].hpp" format is preserved.

Keep in mind that Boost has favored clearness over curtness ;)


Boost list run by bdawes at, gregod at, cpdaniel at, john at