Boost logo

Boost :

From: David Abrahams (david.abrahams_at_[hidden])
Date: 2002-07-24 07:04:36

From: "Aleksey Gurtovoy" <agurtovoy_at_[hidden]>

> > I kind of like Mat Marcus' 'quote' terminology, where
> > metafunction classes are called 'quoted metafunctions', and
> > meta_fun[N] is spelled quote[N]. Have you considered it?
> Considering now :). Glad you've suggested an alternative, because I am
> happy with 'meta_fun'. As David has noted, it sounds like it's making a
> metafunction, not a metafunction class; in that respect, I think that
> the previous 'make_f' spelling was better - at least it didn't misguide
> I went with 'meta_fun' because I couldn't think of anything better, and I
> was running out of time scheduled for the renaming task (I also
> 'to_mfc' or 'as_mfc' - where "mfc" stands for metafunction class, but
> one was quickly discarded for obvious reasons :).
> In any case, I like "quote", although it's slightly out of the current
> terminology (which I would be reluctant to change). If something even
> won't come up till the end of the review, I guess 'meta_fun' will be
> to 'quote'.

In favor of meta_fun, it's analogous to ptr_fun and mem_fun. That doesn't
make me like it, though ;-).


Boost list run by bdawes at, gregod at, cpdaniel at, john at