Boost logo

Boost :

From: Mat Marcus (mmarcus_at_[hidden])
Date: 2002-07-25 00:14:17

>> From: "Peter Dimov" <pdimov_at_[hidden]>
>> I kind of like Mat Marcus' 'quote' terminology, where metafunction classes
>> are called 'quoted metafunctions', and meta_fun[N] is spelled quote[N].
>> Have you considered it?

David Abrahams <david.abrahams_at_[hidden]> replies
> I think I prefer "metafunction class" to "quoted metafunction" for ordinary
> use, but I have to agree with Peter's suggestion in this case.
> meta_fun1<foo> sounds like it's making a metafunction, not a metafunction
> class.

Just a few comments about naming... I know we've been over this before so I won't suggest 'quoted metafunction' for the general purpose name again. But 'metafunction class' really doesn't click for me. Let me spend a moment guessing at why you chose the name metafunction class.

<begin speculation>
Presumably the current name tries to leverage terminology familiar to the reader by making an analogy with 'function object'. That is,

  function is to function object
  meta-function is to meta-'function object'

Meta-'function object' could also be spelled metafunction metaobject (by the distributive law :-)). And metaobjects can be viewed as classes, thus the name metafunction class.
<end speculation>

Unfortunately, 'metafunction class' does not immediately bring meta(function object) to my mind. For such an end, perhaps the name 'metafunctor' would be better?

Also, what ever happened to then proposal for the name ct_if?



Boost list run by bdawes at, gregod at, cpdaniel at, john at