Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-07-26 10:12:21

From: "Jeremy Siek" <jsiek_at_[hidden]>

> On Fri, 26 Jul 2002, David Abrahams wrote:
> dave>
> dave> As a replacement for the existing iterator_adaptor? Do you really
> dave> want to drop "adaptor" from the name? It's not a "Policy builder"
> dave> pattern, after all...
> Well, iterator_adaptor really has two purposes: adapting and creating
> scratch. It seems to me that the name "builder" encompasses both of these
> purposes better than "adaptor".

Even "creating from scratch" can be seen as adapting the Base type, though.
I think seeing it that way tends to simplify understanding the design.

           David Abrahams * Boost Consulting
dave_at_[hidden] *

Boost list run by bdawes at, gregod at, cpdaniel at, john at