Boost logo

Boost :

From: Jeremy Siek (jsiek_at_[hidden])
Date: 2002-07-26 10:07:41

On Fri, 26 Jul 2002, David Abrahams wrote:
dave> As a replacement for the existing iterator_adaptor? Do you really
dave> want to drop "adaptor" from the name? It's not a "Policy builder"
dave> pattern, after all...

Well, iterator_adaptor really has two purposes: adapting and creating from
scratch. It seems to me that the name "builder" encompasses both of these
purposes better than "adaptor".


 Jeremy Siek
 Ph.D. Student, Indiana Univ. B'ton email: jsiek_at_[hidden]
 C++ Booster ( office phone: (812) 855-3608

Boost list run by bdawes at, gregod at, cpdaniel at, john at