Boost logo

Boost :

From: Douglas Gregor (gregod_at_[hidden])
Date: 2002-08-04 21:03:04

On Sunday 04 August 2002 09:22 pm, Andrew J Bromage wrote:
> The problem is that while tribools have a well-understood calculus,
> they are suited to many varied interpretations. Calling the third
> value "unknown", "undefined", "maybe", "bottom" or whatever sounds
> to me like calling your floating point type "length" or "probability".
> Unfortunately, I don't think there is a better name, so I'm not
> going to argue with whatever is chosen.
> Cheers,
> Andrew Bromage

Here's my last potential suggestion: "true_or_false". Otherwise, I'm going for
"unknown" :)


Boost list run by bdawes at, gregod at, cpdaniel at, john at