From: Matthew Hurd (matt_at_[hidden])
Date: 2002-08-04 21:52:03
In the GUI check box example it mean true_and_false. Other times it may
mean unknown rather than true_or_false, there is a subtle difference.
----- Original Message -----
From: "Douglas Gregor" <gregod_at_[hidden]>
Sent: Monday, August 05, 2002 12:03 PM
Subject: Re: [boost] 3-state boolean type
> On Sunday 04 August 2002 09:22 pm, Andrew J Bromage wrote:
> > The problem is that while tribools have a well-understood calculus,
> > they are suited to many varied interpretations. Calling the third
> > value "unknown", "undefined", "maybe", "bottom" or whatever sounds
> > to me like calling your floating point type "length" or "probability".
> > Unfortunately, I don't think there is a better name, so I'm not
> > going to argue with whatever is chosen.
> > Cheers,
> > Andrew Bromage
> Here's my last potential suggestion: "true_or_false". Otherwise, I'm going
> "unknown" :)
> Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk