|
Boost : |
From: Rob Stewart (stewart_at_[hidden])
Date: 2002-08-09 10:16:48
From: "Peter Dimov" <pdimov_at_[hidden]>
>
> * New header boost/throw.hpp:
>
> #ifdef BOOST_NO_EXCEPTIONS
>
> #include <exception>
>
> void boost_throw(std::exception const & e); // user defined
>
> #else
>
> template<class E> void boost_throw(E const & e)
> {
> throw e;
> }
Wouldn't "raise" be a better name than "throw?" That is, "boost_raise" instead
of "boost_throw." You could even be more verbose and make it
"boost_raise_exception."
-- Rob Stewart stewart_at_[hidden] Software Engineer http://www.sig.com Susquehanna International Group, LLP using std::disclaimer;
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk