Boost logo

Boost :

From: David Bergman (davidb_at_[hidden])
Date: 2002-08-28 15:20:49

I think he meant that it is no more discrete than other "computational
sets" around here, such as the STL set. They are all discrete (although
I think it is a bit overkill to refer to the obvious discrete basic
property of computations; a set of "double" should not be considered
discrete, conceptually).


-----Original Message-----
From: boost-bounces_at_[hidden]
[mailto:boost-bounces_at_[hidden]] On Behalf Of spamjunk_at_[hidden]
Sent: Wednesday, August 28, 2002 4:07 PM
To: boost_at_[hidden]
Subject: Re: [boost] powerset

And what exactly makes it non-discrete?

> > >If all the elements of the set are known at compile time, why do
> > >you need to store the bits at all? Your class can encode the
> > >information in its type, thus, your class can consume zero bytes.
> >
> > right up until you need to add (or subtract) something that isn't
> > knows
> > until runtime.
> ....which doesn't always happen. There are certainly things I could
> use it for at compile-time, rather than my existing practice of
> generating a header file containing an array of magic numbers with an
> external program.
> Back to naming: this new proposed set is no more discrete than the
> STL's set, so "discrete_set" is a misnomer. I think that the best
> name I've heard so far here for it (other than "set", which is taken
> :-) is "powerset". Was there something wrong with that suggestion?
> Also (albeit without having put much thought into it) it seems to me
> that
> there ought to be a lot of overlap with bitset/dyn_bitset/etc. Can
all of
> these be rolled into one somehow?
> Dave
> _______________________________________________
> Unsubscribe & other changes:

Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at