Boost logo

Boost :

From: spamjunk_at_[hidden]
Date: 2002-08-30 12:57:48

> Anyhow, suggestions such as "selection_of", "domain" (with the Finite
> Domain semantics, rather than the algebraic semantics),
> "constrained_set" are all at least logical. Alternatives such as
> "finite_set" are not, since they do not reveal the discriminating nature
> of this structure (these sets are no more finite than many other sets,
> as pointed out: 2^32 is not extremely finite in terms of modern
> computers, unfortunately; I wish it was).
> /David

Saying that "constrained_set" is acceptable and "finite_set" is not, is I think,
pull hairs (or how ever that expression goes). I would find either acceptable.

In naming this set, I wouldn't worry so much about any involved mathematical
concepts or the set's implementation. Any name from derived from math that fits
(subjective, of course), but morphs a little (i.e., "powerset"), may still be
acceptable. After all, functor and vector doesn't map exactly to their
mathematical origins, but who cares? You math profs. may, but we code slingers
sure don't. As for names based in the fact that the elements are coded as bits,
I don't like. I prefer names that express what it is design for, not how it
accomplishes it.

Rich Herrick

Boost list run by bdawes at, gregod at, cpdaniel at, john at