From: David Bergman (davidb_at_[hidden])
Date: 2002-08-30 13:26:40
Not a bad suggestion at all. I think neither Prada or the few Prologers
out there (still using bags for holding solutions in indeterministic
problems) would reject the "bag" term completely.
What do you think of my old proposal: domain (without the algebraic
[mailto:boost-bounces_at_[hidden]] On Behalf Of Victor A. Wagner,
Sent: Friday, August 30, 2002 1:56 PM
Subject: RE: [boost] Re: set class
At Friday 2002/08/30 10:17, you wrote:
>The only real discriminating factors of the Spamjunk Set Library, w.r.t
>structures such as std::set, are
>1. Elements are coded (see Goedel's Coding Theorem...) as integers,
>being enums or
> other integerizable elements
>2. There is an explicit universal set for each set application, to
>which all sets are
>These discriminators should affect the naming, not arbitrary "cool, and
>not used in Boost" terms.
my main reason for wanting this in the first place was to get rid of the
(to me) crazy idea that the comparison operators work in lexicographic
"mode" rather than in what any mathematician would call "set" mode.
how about something straightforward, simple, small, and a concept that
everyone can get a handle on: bag<>
lest anyone get upset that we can have only ONE of each kind of element,
multi_bag<> can exist and is left as an exercise for the student.
Victor A. Wagner Jr. http://rudbek.com
PGP RSA fingerprint = 4D20 EBF6 0101 B069 3817 8DBF C846 E47A PGP D-H
fingerprint = 98BC 65E3 1A19 43EC 3908 65B9 F755 E6F4 63BB 9D93 The five
most dangerous words in the English language:
"There oughta be a law"
Unsubscribe & other changes:
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk