Boost logo

Boost :

From: Aleksey Gurtovoy (agurtovoy_at_[hidden])
Date: 2002-10-25 16:21:30

Paul Mensonides wrote:
> Yes, I agree. I'm just pointing out that if files were named
> using the case of their contents, things can get really ugly:

Preprocessor library is obviously an exception here, due to specifics of the
domain; it's not only the case of the component's name and header's name
that doesn't match - the names themselves doesn't match as well.

For instance, "boost/preprocessor/cat.hpp" defines a macro named
BOOST_PP_CAT, not 'boost::preprocessor::CAT' ;). It's easy to get used to
this order of things, though, if you remember that you are dealing with
preprocessor definitions here, so, personally, I am happy with the current

> (This is an example of something *bad*.)
> #include <boost/preprocessor/LIST/detail/FOLD_LEFT.hpp>

Yep, ugly!


Boost list run by bdawes at, gregod at, cpdaniel at, john at