From: David Abrahams (dave_at_[hidden])
Date: 2002-12-09 10:23:07
Toon Knapen <toon.knapen_at_[hidden]> writes:
> On Monday 09 December 2002 15:32, Samuel Krempp wrote:
>> On the opposite hand, using the same kind of naming scheme,
>> #ifdef BOOST_NEED_UNREACHABLE_RETURN
>> return whatever;
> Well all the time I got really confused in this discussion but this proposal
> is very clear to me. I definitly would prefer this one.
Well, on third look I see that this only stimulates warnings on any of
the compilers I have access to. I wonder if it was worth inciting all
this traffic and work for :(
Maybe so: I like to compile with "all warnings are errors" enabled.
I also note that BOOST_NEED_xxx is not consistent with our naming
scheme. It would have to be something like what we have:
-- David Abrahams dave_at_[hidden] * http://www.boost-consulting.com Boost support, enhancements, training, and commercial distribution