Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-12-10 12:40:25

Yitzhak Sapir <yitzhaks_at_[hidden]> writes:

> On Tue, 10 Dec 2002, David Abrahams wrote:
>> And, I suggest
> Since I began wondering whether it was a typo that you used | instead of
> &, since the | obviously always evaluates true, leading me to browse this
> thread, I think something more descriptive (not necessarily as long as the
> following) might be helpful:
> #define WORKAROUND_LAST_CHECKED_AT_VERSION(version) |1 // documentation macro only
> ...

That's awfully verbose, though. And it would need a "BOOST_" prefix,
making it more verbose still.

Given that the meaning of BOOST_WORKAROUND is already non-transparent,
you need to read the documentation to understand it. I think it'd be
best to simply document the "|" convention there.

                       David Abrahams
   dave_at_[hidden] *
Boost support, enhancements, training, and commercial distribution

Boost list run by bdawes at, gregod at, cpdaniel at, john at