From: David Abrahams (dave_at_[hidden])
Date: 2002-12-11 08:08:57
Aleksey Gurtovoy <agurtovoy_at_[hidden]> writes:
> David Abrahams wrote:
>> > I agree completely, and I'll even promise not to change my
>> > mind for at least a week :-)
>> Good! You, Aleksey and I all agree. So shall we go with this
>> definition of BOOST_WORKAROUND from Gennaro Prota?
>> #define BOOST_WORKAROUND(symbol, test) ((symbol != 0) &&
>> (symbol test))
> Looks good to me. How about keeping it in a separate header, though?
> Personally, I am getting annoyed by having to write, for example:
> #include "boost/config.hpp" // for BOOST_STATIC_CONSTANT
> instead of
> #include "boost/config/static_constant.hpp"
> and by tracking down whether a header still needs "boost/config.hpp" include
> after you've removed, let's say, all BOOST_STRICT_CONFIG references.
Fine with me. I never intended to move it until John suggested it.
The two of you can duke it out over this one, as far as I'm concerned ;->
-- David Abrahams dave_at_[hidden] * http://www.boost-consulting.com Boost support, enhancements, training, and commercial distribution
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk