Boost logo

Boost :

From: David Abrahams (dave_at_[hidden])
Date: 2002-12-16 11:58:04

Beman Dawes <bdawes_at_[hidden]> writes:

> At 03:05 AM 12/16/2002, Vladimir Prus wrote:
> >Beman Dawes wrote:
> >> A large number of changes to the Filesystem Library have been
> committed >> to the CVS main trunk.
> >
> >Hi Beman,
> >
> >I've some comments:
> >
> >1. The name 'root_directory' is confusing for me. 'directory' implies
> > you can stick anywhere dir there, whilie only "/" is allowed.
> > Unfortunetely, nothing better comes to mind.
> I've agonized over the names of many of the functions, and feel that
> the current names are a real improvement over earlier names. Both the
> individual names, and the names as they relate to one another are
> better.
> Nevertheless, if anyone can come up with still better names I'll
> welcome the improvement:-)

Given the remarks above, "root" might be an improvement over
"root_directory"... though I admit I don't have a clue about the

                       David Abrahams
   dave_at_[hidden] *
Boost support, enhancements, training, and commercial distribution

Boost list run by bdawes at, gregod at, cpdaniel at, john at