Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2002-12-16 12:23:09

At 11:58 AM 12/16/2002, David Abrahams wrote:

>Beman Dawes <bdawes_at_[hidden]> writes:
>> At 03:05 AM 12/16/2002, Vladimir Prus wrote:
>> >Beman Dawes wrote:
>> >> A large number of changes to the Filesystem Library have been
>> committed >> to the CVS main trunk.
>> >
>> >Hi Beman,
>> >
>> >I've some comments:
>> >
>> >1. The name 'root_directory' is confusing for me. 'directory' implies
>> > you can stick anywhere dir there, whilie only "/" is allowed.
>> > Unfortunetely, nothing better comes to mind.
>> I've agonized over the names of many of the functions, and feel that
>> the current names are a real improvement over earlier names. Both the
>> individual names, and the names as they relate to one another are
>> better.
>> Nevertheless, if anyone can come up with still better names I'll
>> welcome the improvement:-)
>Given the remarks above, "root" might be an improvement over
>"root_directory"... though I admit I don't have a clue about the

The context is important. Really important.

The complete root is defined in the grammar as being made up of the
root-name and the root-directory. (The root-name is always "" on
single-root systems like POSIX.)

Accordingly, the functions to extract those grammar element individually as
strings are named root_name() and root_directory(). The function to extract
those two grammar elements composed into a path is named root_path(). This
is consistent with the naming scheme for the other decomposition functions,
which also match the names used in the grammar.

So it really doesn't work to change just a single name out of context; the
whole picture, including the names used in the grammar, needs to be


Boost list run by bdawes at, gregod at, cpdaniel at, john at