Boost logo

Boost :

From: Howard Hinnant (hinnant_at_[hidden])
Date: 2002-12-17 09:52:07

> isn't the current implementation of is_compound overly complex? Can't
> we
> just change it to basically match:
> is_compound = !is_fundamental
> given a working version of is_fundamental of course, but this seems
> easier than providing an always safe and portable is_class or other
> stuff required for the current version.
> Regards, Daniel
> ~~~~~~~~~~~~~~~~~~~

On Tuesday, December 17, 2002, at 06:59 AM, John Maddock wrote:
> I think you may be on to something, I'll try it out when I have a
> chance,
> thanks!

Fwiw, is_compound = !is_fundamental is how the Metrowerks version of
this utility has been implemented for the last few years.


Boost list run by bdawes at, gregod at, cpdaniel at, john at