From: Eric Friedman (ebf_at_[hidden])
Date: 2003-02-19 19:37:54
Gennadiy Rozental wrote:
> > Eric Friedman wrote:
> > >
> > >> The area would be helped by renaming extract to access.
> > >
> > > I tend to agree the name is confusing. So shall we call it
> > > boost::access<>? Input?
> what about get_value<>?
If extract<> returned a value, I don't think we'd be having this
If anything, your proposal should be to call it get_reference<>, but I
personally find that neither attractive nor particularly clear.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk