Boost logo

Boost :

From: Alisdair Meredith (alisdair.meredith_at_[hidden])
Date: 2003-02-28 09:25:00

Martin Wille wrote:

> Otherwise, I completely agree with Joel's reasoning that
> "resource" is the best name.

I have mulled it over for a while, and tried to imagine myself coming at
the issue for the first time, as someone learning C++ rather than
learning/devising new tricks.

In this case, I find resource seems to work best, even though it is not
my original term of choice.

I certainly prefer it over anything with an abbreviation which may work
for native English speakers might break the word-association for the
rest [maybe being overly patronising here, after all it's not MY problem

It's short enough, it's a noun, it carries less baggage for other
applications than most the other suggested terms. I suspect once we are
used to it (assuming it is chosen), we will wonder what the naming
problem was!

But as so often in software, finding the right name is the hardest part
of the problem <g> [Especially for the more fundamental concepts]


Boost list run by bdawes at, gregod at, cpdaniel at, john at