Boost logo

Boost :

From: Paul A. Bristow (boost_at_[hidden])
Date: 2003-02-28 09:35:14

I feel like the ball boy at Wimbledon here,
interfering in a rare old ding-dong of the match of the week

de Guzman v. Slettebø

who seem to be about 40 all so far?

As someone who grew up happily on pointerless language, I don't automatically
think resource when I read pointer or ptr.

How about


and/or perhaps (and probably not)

managed_resources<widgets> if it is a list?

A bit long, but MUCH clearer?


Paul A Bristow, Prizet Farmhouse, Kendal, Cumbria, LA8 8AB UK
+44 1539 561830 Mobile +44 7714 33 02 04
Mobile mailto:pabristow_at_[hidden]

> > "resource_manager" starts to look attractive, again. ;)
> Perhaps. But there's a *better* and *shorter* alternative that very well fits
> the description. We can say: linear_list_of_items_manager<int>, YUCK!
> Instead, we say list<int>. The management *is* implicit!
> Also, in general, I would say that any name suffixed by "_manager" are best
> used for classes that manage *many* things simultaneously, NOT JUST ONE.
> Take a window_manager for example. It is something that manages the operations
> of many windows. In the Macintosh, for example, the resource manager manages
> "all* the resources in an application.
> --
> Joel de Guzman
> joel at
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at