Boost logo

Boost :

From: Paul Mensonides (pmenso57_at_[hidden])
Date: 2003-04-14 13:44:57

Joel de Guzman wrote:
> Gennaro Prota wrote:
>> On Mon, 14 Apr 2003 08:48:34 +0800, "Joel de Guzman"
>> <djowel_at_[hidden]> wrote:
>>> 2) region is not intuitive, I'm gravitating towards "module", along
>>> with its friends "import" and "export".
>> Weren't you the guy who brought up subjectivity? :-) Please, let's
>> avoid Parkinson's Bicycle Shed.
> You are right of course :-) Pardon me... ahem.... :-)
>> I like either 'region' and 'section', for instance. The term
>> 'section' also being in accordance with the terminology used in
>> clause 16 (FWIW, once I proposed a very similar idea on comp.std.c++
>> and the corresponding addition to clause 16 was, in fact, called
>> def-section. But who cares? :-))
> Any name is fine, I have no strong opinion in fact. "module"
> just blends well with "export" and "import" in the Modula-2 sense.
> So, there's a precedence, FWIW.

There is always preference of course, and five different people have five
different "favorite sets of names." This is subjective, yet it is still a valid
topic for discussion. Keep in mind however, that of all things, the names
chosen are less important than functionality, and are also the most fluid and
easy changed. At this point, the whole idea is somewhat preliminary.

Paul Mensonides

Boost list run by bdawes at, gregod at, cpdaniel at, john at