Boost logo

Boost :

From: Justin M. Lewis (boost_at_[hidden])
Date: 2003-05-03 13:30:05

It would be good for code that's going to become old. It would be good in a
case where you know the code is going to have to be supported for years. I
don't think I've ever suggested going and rewriting whole projects to use

And as I've already point out, it's not possible to make a function's intent
clear with a name.

----- Original Message -----
From: "Terje Slettebø" <tslettebo_at_[hidden]>
To: "Boost mailing list" <boost_at_[hidden]>
Sent: Saturday, May 03, 2003 6:08 AM
Subject: Re: [boost] Re: in/out parameters, codingstylesandmaintenance

> It could seem that this proposal is caught between a rock and a hard
> It was said that it would be particularly useful for old code, where it
> not be clear what the functions do. But old code doesn't use the
> so it can't be used there, unless the code is retrofitted with it.
> as Dave Abrahams pointed out, if you can retrofit the convention, you may
> also redesign the interface, so it's clear what it does.
> Even if you can't retrofit functions, it's possible to wrap the API.
> Then it was said that it may be useful for new code. However, with new
> there may be better ways of doing it, so it's clear what functions do.
> Regards,
> Terje
> _______________________________________________
> Unsubscribe & other changes:

Boost list run by bdawes at, gregod at, cpdaniel at, john at