Boost logo

Boost :

From: Darren Cook (darren_at_[hidden])
Date: 2003-05-08 03:04:09


> I think ENFORCE_ASSERT would be a bit confusing. Enforcements and assertions
> serve very very different purposes. How about ALWAYS_ASSERT?

That might get confused with "ASSERT(false)" :-).

If VERIFY is used in MFC to mean an assert even in release mode then that is
probably the best name.

Darren

>>>I wonder it something like this would be possible:
>>>void foo() {
>>> int* x = ENFORCE_ASSERT(get_something());
>>> // equivalent to:
>>> // int* x = get_something();
>>> // if (!x) { assert(false); return; }
>>
>>TRUE!!!
>>I could allow for BOOST_VERIFY - something like the MFC's VERIFY.
>>And, I will have to allow for some syntax to be able to return something
>>from the function.


Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk