From: Vladimir Prus (ghost_at_[hidden])
Date: 2003-05-23 08:31:51
James Curran wrote:
> Chuck Messenger wrote:
>> OK, how about this syntax, to make it much more clear what is being
>> returned (and, at the same time, to reduce the verbiage):
>> (param("magic|value|magic value for the program") >> magic)
>> (param("val||some value with a default", defaultValue) >>
>> val) ...
> I'm still considering the merging of the strings, but I _do_ like the
> syntax. It clear indicating in the code what's going to be modified.
As for me, I'm a bit unsure about introducing new syntax. In this case, I'm
not sure overloading of >> is 100% intuitive --- one can assume that value
of "magic" is read from "param" result, for example.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk