Boost logo

Boost :

From: James Curran (jamescurran_at_[hidden])
Date: 2003-05-23 08:18:59

Chuck Messenger wrote:
> OK, how about this syntax, to make it much more clear what is being
> returned (and, at the same time, to reduce the verbiage):
> desc.add_options()
> ...
> (param("magic|value|magic value for the program") >> magic)
> (param("val||some value with a default", defaultValue) >>
> val) ...
> ;

    I'm still considering the merging of the strings, but I _do_ like the >>
syntax. It clear indicating in the code what's going to be modified.

James Curran (personal) (professional)

Boost list run by bdawes at, gregod at, cpdaniel at, john at