Boost logo

Boost :

From: Glen Knowles (gknowles_at_[hidden])
Date: 2003-06-25 20:07:57

From: Stefan Seefeld [mailto:seefeld_at_[hidden]]
>>Daryle Walker wrote:
>> On Tuesday, June 24, 2003, at 8:12 PM, Stefan Seefeld wrote:
>> [SNIP]
>>> As the wrapper objects have reference semantics, I append '_ptr' to
>>> their name to stress that fact. A practical side-effect of this is
>> Shouldn't the type names use a suffix of "_ref" instead? (I don't need
>> to know that they're [possibly] implemented as pointers.)
>it seems 'pointer' has for you a very precise (C/C++) meaning.
>I just used _ptr the same way it is used in CORBA (i.e. the C++
>mapping), where it doesn't imply anything about the implementation.
>I believe _ptr and _ref are fairly equivalent.

_ptr has a very specific meaning in CORBA as well, you must explicitly
manage the deletion of the object yourself, like, well... a pointer. If you
must use the CORBA namings this, at my first look, seems closer to _var then
_ptr. At which point I also think _ref is a better choice.


Boost list run by bdawes at, gregod at, cpdaniel at, john at