From: Reid Sweatman (drunkardswalk_at_[hidden])
Date: 2003-08-04 05:11:34
> -----Original Message-----
> From: boost-bounces_at_[hidden]
> [mailto:boost-bounces_at_[hidden]]On Behalf Of Thomas Witt
> Sent: Monday, August 04, 2003 3:05 AM
> To: Boost mailing list
> Subject: Re: [boost] RE: Re: Filesystem: create_directories
> Vladimir Prus wrote:
> | Reid Sweatman wrote:
> | So, to summarize, I've no problem with the current name that I've
> | introduced.
> :-). Seriously having two functions that differ only by number is a
> no-go to me.
Some confusion in headers here; I wasn't the one who said that. No offense.
> | "demand_directory" is
> | good. One problem is that "demand" still does not communicate to me that
> | something will be created.
> And that's good because creation does not necessarily happen. Not until
> you require that create_directories creates at least one directory. I
> don't see this in the documentation and I don't think this would be the
> most usable semantics.
Some of this I did just fumble around, but you won't have seen those
messages yet. Not trying to create trouble, just maybe be a bit of yeast in
the ferment <g>.
Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk