Boost logo

Boost :

From: Reid Sweatman (drunkardswalk_at_[hidden])
Date: 2003-08-04 05:16:23

> -----Original Message-----
> From: boost-bounces_at_[hidden]
> [mailto:boost-bounces_at_[hidden]]On Behalf Of Vladimir Prus
> Sent: Monday, August 04, 2003 12:51 AM
> To: boost_at_[hidden]
> Subject: [boost] RE: Re: Filesystem: create_directories
> Reid Sweatman wrote:


> FWIW, I don't like
> - "create_full_directory", because I don't understand what it means for
> directory to be full. "Full of files" is one interpretation which is not
> correct.
> - "create_rooted_directory", because I don't know what's "rooted"
> directory.
> - "create_directory_and_path", because how if one can create
> directory, one
> can name that directory, and the path should already exist.

Well, I knew they were imperfect attempts. The semantic difficulty you have
with them is due to something I mentioned in a just-posted message (this
thread is fragmenting in my reader for some reason) you'll see shortly,
namely that a directory and a path are different things, and yet are often
used interchangeably. I think in a library as fundamental as this the
semantics implied by the names should be as tight as possible.

> So, to summarize, I've no problem with the current name that I've
> introduced. Of other suggestions "create_directory_and_parents" looks best
> to me. "ensure_directory_exists" does not imply any operational semantic
> (i.e. the name does not say that the directory will be created. One might
> expect exception to be thrown if dir does not exist).
> "demand_directory" is
> good. One problem is that "demand" still does not communicate to me that
> something will be created.


Reid Sweatman

Boost list run by bdawes at, gregod at, cpdaniel at, john at