Boost logo

Boost :

From: Beman Dawes (bdawes_at_[hidden])
Date: 2003-08-06 11:34:31

At 11:32 AM 8/6/2003, David Abrahams wrote:
>I think this is a badly-chosen name. Both POSIX and Python have a
>basename function which does roughly what our leaf() function does.
> ...
>I don't think we should use creative naming in cases like this one.

The naming scheme based the root/branch/leaf tree metaphor was carefully
worked out and reviewed over a long period of time. It would not be
beneficial to use a different naming scheme for one of the decomposition
function names, IMO.


Boost list run by bdawes at, gregod at, cpdaniel at, john at