Boost logo

Boost :

From: Alexander Nasonov (alnsn-mycop_at_[hidden])
Date: 2003-08-13 07:56:17


graydon hoare wrote:
> an inter-thread pipe might also be referred to as a synchronization
> channel, if you want to avoid confusion about names (pipes being a
> particular OS object).
>
> -graydon

Synchronization channel sounds good except that stream names are too long.

synchronization_channel channel; // good

// too long?
synchronization_channel_istream in(channel);
synchronization_channel_ostream out(channel);

-- 
Alexander Nasonov
Remove minus and all between minus and at from my e-mail for timely response

Boost list run by bdawes at acm.org, gregod at cs.rpi.edu, cpdaniel at pacbell.net, john at johnmaddock.co.uk