Boost logo

Boost :

From: Chris Trengove (trengove_at_[hidden])
Date: 2003-08-15 18:05:10

"Jeff Garland" <jeff_at_[hidden]> wrote in message
> Sure, can do. What would you call it: merge_inclusive, earliest_latest,
> merge to union and call it merge, something else?

Yes, the hardest thing is to think of a name. I don't think you can rename
merge to union, since I suspect you chose merge originally because "union"
is a keyword. In strict set terms, the proposed new function really is the
union, whereas the existing merge is something else, a sort of "conditional"

Maybe you can leave merge as is, and call the new thing simple_union, or
union_with, to get around the keyword problem. I think I favour


Boost list run by bdawes at, gregod at, cpdaniel at, john at