Boost logo

Boost :

From: Jeff Garland (jeff_at_[hidden])
Date: 2003-08-15 20:24:11

On Sat, 16 Aug 2003 09:05:10 +1000, Chris Trengove wrote
> "Jeff Garland" <jeff_at_[hidden]> wrote in message
> > Sure, can do. What would you call it: merge_inclusive, earliest_latest,
> rename
> > merge to union and call it merge, something else?
> Yes, the hardest thing is to think of a name. I don't think you can rename
> merge to union, since I suspect you chose merge originally because "union"
> is a keyword. In strict set terms, the proposed new function really

I think it is ok b/c it is a member function, but that's a good point.

> is the union, whereas the existing merge is something else, a sort
> of "conditional" union.

I see what you are thinking, it isn't like a normal set union, which is
probably why all called it merge...
> Maybe you can leave merge as is, and call the new thing simple_union,
> or union_with, to get around the keyword problem. I think I favour
> simple_union.

I don't think the it is technically a union because the result draws in
points in the time period that aren't part of either of the initial periods.
Anyway I wrote the code as merge_inclusive so unless you have a major
objection I'll leave it that way pending a better idea...


Boost list run by bdawes at, gregod at, cpdaniel at, john at